Crashes with picture in document header

Aug 22, 2009 at 4:02 PM

Love the tool!  One minor problem, if there is a picture in the document header then the redaction tool will hang up at the end of the process.  While it took a while to figure out what was happening, it is easy to work around - delete the picture from your header before "Redact document", then when the new document is complete simply go in and add back the picture.  Hopefully they can fix the bug but if not still an amazing tool!  Much mahalo (many thanks), Damon

Coordinator
Aug 29, 2009 at 4:52 PM

Great catch! I believe I have a fix for this - I'll compile and post a 1.1 beta version this weekend that should address it.

Aug 29, 2009 at 8:22 PM
Tristan,

I also found that it struggled if I redacted merged cells in a table and/or table headers - when I took the merged header out of the redaction then it worked fine.

Many thanks for the quick work on the new beta!
Damon


From: [email removed]
To: [email removed]
Date: Sat, 29 Aug 2009 09:52:57 -0700
Subject: Re: Crashes with picture in document header [redaction:66687]

From: tristand
Great catch! I believe I have a fix for this - I'll compile and post a 1.1 beta version this weekend that should address it.
Coordinator
Aug 30, 2009 at 6:25 PM

interesting - is this problem also in headers? does the redaction fail, hang, or just take a long time? would you be able to provide a sample file with dummy content that experiences this (I can't reproduce it)?

Aug 30, 2009 at 11:50 PM
Finally replicated. In this file when I run it I get a generic error message "an error was encountered while redacting this document". I ran it several times with no problem testing various things (table going across pages, etc...); error did not happen until I merged the box in the header.

The tool rocks, saved me some serious time over the past week!



i'm EMAILING FOR THE GREATER GOOD
Join me



From: [email removed]
To: [email removed]
Date: Sun, 30 Aug 2009 11:25:42 -0700
Subject: Re: Crashes with picture in document header [redaction:66687]

From: tristand
interesting - is this problem also in headers? does the redaction fail, hang, or just take a long time? would you be able to provide a sample file with dummy content that experiences this (I can't reproduce it)?
Coordinator
Sep 1, 2009 at 6:02 AM
Edited Sep 1, 2009 at 6:03 AM

I've uploaded a beta version of v1.1 that fixes the issue you reported with pictures (thanks again). If you do have a test document (not your main one obviously, since I'm sure that has personal information) that demonstrates the table issue, I'd love to see if I can fix that one as well before declaring 1.1 final.

1.1 is here: http://redaction.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=32251

Thanks again!

Sep 2, 2009 at 7:57 PM
Sorry for the delay, here is the file. :)








i'm EMAILING FOR THE GREATER GOOD
Join me




From: [email removed]
To: [email removed]
Date: Mon, 31 Aug 2009 23:02:18 -0700
Subject: Re: Crashes with picture in document header [redaction:66687]

From: tristand
I've uploaded a beta version of v1.1 that fixes the issue you reported with pictures (thanks again). If you do have a test document (not your main one obviously, since I'm sure that has personal information) that demonstrates the table issue, I'd love to see if I can fix that one as well before declaring 1.1 final.
Thanks again!
Coordinator
Sep 3, 2009 at 4:41 PM

It looks like the attachment is getting lost somewhere along the way - would you mind creating a new bug on the Issue Tracker page and using the attachment field there to attach it? Thanks!

Coordinator
Sep 9, 2009 at 2:39 AM

Bug's fixed (was out of town for the weekend) - will post an updated v1.1 tomorrow.

Thanks again for the report!